Kawasaki Motorcycle Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Okay guys so I bought a 2005 Kawasaki zx6r a few months ago and the previous owner had installed a garage door opener in the tail area and while I was going through cleaning up the wiring I came across this.. I can push that black button and a red light shows up on it and stays lit. It was Velcro’d on by the servo motor and ecu... Any ideas on what this is??? Could it also be a part of the garage door opener that I ripped out? I’m lost here. Has a red wire that looks to go all the way down to the motor and that’s it. ANY HELP WOULD BE AWESOME!
7E20D215-5122-49B3-AC16-AFB32061C179.jpeg
 

·
Registered
Joined
·
26 Posts
Does it have a label on the other side? Looks like an old style fuel controller. Post this on the ZX6 forum and I'll bet you would have a more concise answer within hours.

EDIT: I knew I saw that somewhere. It was on the ZX10 Forum. It's an old style speedo healer. What is this ?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Does it have a label on the other side? Looks like an old style fuel controller. Post this on the ZX6 forum and I'll bet you would have a more concise answer within hours.

EDIT: I knew I saw that somewhere. It was on the ZX10 Forum. It's an old style speedo healer. What is this ?
Where can I find the ZX6 forum?
 

·
Pursebully
Joined
·
38,898 Posts
It's an early version of the SpeedoHealer. It's there to correct the speedometer when sprockets are changed. The speedo on your bike takes pulses from a sensor near the drive sprocket. When sprockets are changed, the speedometer displays incorrectly. This module counts the pulses and adjusts them before sending them on to the speedometer.
 
  • Like
Reactions: GR rider

·
Registered
Joined
·
4 Posts
Discussion Starter #5
When I found it all switches were pointed down and the red light wasn’t lit up, does that mean it’s off? Is there anyway to check to see if it’s actually working and should I recalibrate it and if so where do I go to do that. Thank you
 

·
Registered
Joined
·
26 Posts
Where can I find the ZX6 forum?
Type "ZX6 Forum" in to google. It is the very first result.

When I found it all switches were pointed down and the red light wasn’t lit up, does that mean it’s off? Is there anyway to check to see if it’s actually working and should I recalibrate it and if so where do I go to do that. Thank you
You will also need to use a google search to find the instructions. Or you could click the link I posted earlier and follow that thread to give you all the answers you need.
 

·
Pursebully
Joined
·
38,898 Posts
  • Like
Reactions: GR rider

·
Registered
Joined
·
4 Posts
Discussion Starter #8
Thank you! I did some more digging last night and found those instructions, weird because pictures of these speed healer v3 are few and far between so it must be old as dirt. I’m gonna try to clear it and re calibrate it and see what happens. Thank you guys!
 

·
Pursebully
Joined
·
38,898 Posts
Mine was purchased somewhere around 2007 if I remember correctly so yeah, they're old.
 
1 - 9 of 9 Posts
Top