Need Help Soo Lost - KawiForums - Kawasaki Motorcycle Forums
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 07-25-2019, 05:52 PM Thread Starter
Jr. Member
 
Join Date: Sep 2018
Posts: 2
 
Garage
Need Help Soo Lost

2007 Ninja 650R - purchased OEM stator and gasket - alls good - went to replace it back on the bike and now it doesnt seem fir fit properly. I read posts of how it sucks into the bike because of the magnet. Which it does BUT the bottom portion of the stator cover sucks right in and the mid to top part DOES NOT. Still has a gap. Ive re checked the gears and how I placed them and they match other posts with photos but still NOT sucking up against the main part. What am I doing wrong?? This is driving me nuts.
Wayner is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 08-16-2019, 11:31 PM
Jr. Member
 
Join Date: Aug 2015
Posts: 175
  
Quote:
Originally Posted by Wayner View Post
2007 Ninja 650R - purchased OEM stator and gasket - alls good - went to replace it back on the bike and now it doesnt seem fir fit properly. I read posts of how it sucks into the bike because of the magnet. Which it does BUT the bottom portion of the stator cover sucks right in and the mid to top part DOES NOT. Still has a gap. Ive re checked the gears and how I placed them and they match other posts with photos but still NOT sucking up against the main part. What am I doing wrong?? This is driving me nuts.

You are tightening the bolts in a star, pattern, right? Whenever your tightening something like that, you're supposed to tighten the bolts partially moving from one to the furthest away bolt so that you get things tightened evenly. That way, you shouldn't have the cover warp under uneven pressure on one side.



I'd remove it and verify that the cover hasn't becomed warped. I'd then make sure that the internal parts on the stator are properly seated before trying again.
pfranks is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the KawiForums - Kawasaki Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome