2013 ZX6R Front Break issue - KawiForums - Kawasaki Motorcycle Forums
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 07-16-2019, 06:01 PM Thread Starter
Jr. Member
 
Join Date: Jan 2012
Posts: 28
 
Question 2013 ZX6R Front Break issue

I did not ride the bike for few months as it rains everyday here. Today I ride the bike and noticed front break is very weak. Breaking power does not kick in until lever travels halfway!! Pretty scary.



I am guessing, Low break fluid, Bubble in break line or does the moisture in breakfluid can cause this?
Is this why people wrap something on break fluid container?
What could cause such symptoms?


I know for sure that pads are new. Any thoughts !!
Thanks in advance.
theteju is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 07-16-2019, 08:30 PM
bpe
Member
 
bpe's Avatar
 
Join Date: Dec 2018
Location: Atlanta,GA
Posts: 369
   
Garage
Quote:
Originally Posted by theteju View Post
Low break fluid, Bubble in break line or does the moisture in breakfluid .
All of the above.
When you change the pads, completely change the fluid and bleed it good.
Wouldn't be a bad idea to disassemble the caliper and clean it out and replace the seals.

2006 EX500r
Purchased new in July 2006, 0 miles.
Miles as of January 2019 102,137 miles
bpe is offline  
post #3 of 3 (permalink) Old 08-11-2019, 02:20 PM Thread Starter
Jr. Member
 
Join Date: Jan 2012
Posts: 28
 
This is an Update :


I bleeded the fresh break fluid. the old one look pretty turbid compared to new clear break fluid. The break worked great for a week. Two weeks later the break is again Spongy. (Spongy in sense, the lever goes more than half way before the breaking power comes in)


Looks like I may have leak somewhere in the system.
Or it is time to replace the seals. I have not done this before.

Lets see.

Any comment would be appreciated. I shall update this post again, It may help someone out there.


Thanks.
theteju is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the KawiForums - Kawasaki Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome