02 ZX6R Speedo, Tach, Clock, and Odometer Not Working - KawiForums - Kawasaki Motorcycle Forums
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 06-24-2019, 08:24 AM Thread Starter
Jr. Member
 
Join Date: Jun 2019
Posts: 2
 
02 ZX6R Speedo, Tach, Clock, and Odometer Not Working

I just pulled my 02 ZX6R out of storage and fired it up. Battery has been on the tender and reads 11.8 volts. Everything on the bike works but I cant seem to get the MPH and RPM needles to move. Also the digital odometer and clock are not working. All of the gauge cluster is back lit including the digital odometer and clock area, turn signal indicators working, neutral indicator working, etc. I unplugged and replugged in the wiring harness to the gauge cluster and it seems tight. Disconnected and reconnected the battery for a restart and same issue. Any ideas???
02yellowzx6r is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 06-28-2019, 01:50 PM
Intermediate Member
 
Join Date: Jun 2006
Location: Detroit, Michigan, United States.
Posts: 2,196
           
11.8 volts is really low for a battery let alone a battery that just came off a charger, maintainer, or tender (in your case). I'd charge the battery and hope that fixes it otherwise you have some electrical diagnosing to do. If the charging the battery to 12.6+ volts doesn't fix it the next easiest thing to try is unplugging the connector on the opposite end of the gauge cluster harness, at the ECU or wherever else it goes.
killer2600 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the KawiForums - Kawasaki Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome